ExtensionNotFoundException: No extension with id 'SECURE' for ExtensionPoint[....GridMode]

Problem

After upgrading Datameer to a 5.11 release that is connected to a Kerberos Secured cluster, an error message is received 

ExtensionNotFoundException: No extension with id 'SECURE' for ExtensionPoint[....GridMode]  

Background

As of Datameer v5.11, Kerberos authentication is available with Datameer's Advanced Governance through a separate plug-in.

Solution

Contact your Customer Success Manager (CSM) or Datameer Support to receive a download link for the necessary plugin-kerberos-5.11.<bugfixrelease>.zip

To install the plug-in:

  • Stop the Datameer service via ./bin/conductor.sh stop
  • Copy the downloaded plugin-kerberos-5.11.<bugfixrelease>.zip into <datameer-install-path/plugins>
  • Start the Datameer service via ./bin/conductor.sh stop