How to Enable a New TLS Version in Java 7

Goal

To ensure secure connections to websites, Datameer uses TLS. Java 7 is used by default with Datameer, and Java 7 uses TLS version 1.0. Learn how to change the version of TLS with Java.

Learn

You can enable a new version of TLS with Java 7 in several different ways:

  • For each application, enter this command:
    java ... -Dhttps.protocols=TLSv1.1,TLSv1.2 ...
  • Using JAVA_OPTS, enter the following command in your .profile, shell rc (to affect all Java programs run by the user), or conductor.sh (to just affect Datameer):
    export JAVA_OPTS="${JAVA_OPTS} -Dhttps.protocols=TLSv1.1,TLSv1.2"
  • Using global Java options for Windows users, edit the Java Options in the Control Panel
  • Using global Java options for Mac, use these options.