Many WARN Messages After Upgrading to 6.3 or 6.4 During Conductor Startup

Problem

After upgrading to 6.3 or 6.4, A number of WARN messages are seen during conductor startup:

Example:

[anonymous] WARN [2018-01-26 14:19:14.677] [main] (PluginManifestParser.java:125) - Failed to parse /app/datameer/Datameer-6.4.3-cdh-5.13.0/plugins/plugin.xml. java.lang.RuntimeException: java.io.FileNotFoundException: /app/datameer/Datameer-6.4.3-cdh-5.13.0/plugins/plugin.xml (No such file or directory)
[anonymous] WARN [2018-01-26 14:46:48.696] [main] (HqlSqlWalker.java:931) - [DEPRECATION] Encountered positional parameter near line 1, column 231.  Positional parameter are considered deprecated; use named parameters or JPA-style positional parameters instead.

 

Cause

These messages are the result of two known bugs being addressed in DAP-32979 and DAP-34932.

 

Solution

While these WARN messages do not cause any adverse effects within Datameer, they will be fixed in a future release.