Datameer 6 Plugins Won't Install

3 followers
0
Avatar

Hi, sorry for the trouble. For some reason now Datameer 6 wont let me install plugins. It says the folder does not exist (it does) and does not have permissions. Can you help me out?

Alvaro Rattinger

7 comments

  • Avatar
    Joel Stewart

    [Moved to a new thread on your behalf Alvaro]

    Which plugin are you attempting to install? I can try to reproduce this in a similar environment. 

    0
  • Avatar
    Joel Stewart

    Could you share the exact log messages from the conductor log? 

    Also, it sounds like this is a custom plugin. What version of the SDK was this plugin compiled with? What version of Datameer is it trying to be installed into? 

    0
  • Avatar
    Alvaro Rattinger

    The log states there is no plugin folder or that permissions are not correct.  I am trying to install in Datameer 6.11 no idea what SDk was used, the plugin was created by Datameer .

    0
  • Avatar
    Joel Stewart

    What are the file system permissions for the plugins directory? What system user is being used to start Datameer? 

    0
  • Avatar
    Konsta Danyliuk

    Hello Alvaro,

    As far as I understand, you are trying to upload plugin-linear-algebra and getting below error.

    "Installation of "plugin-linear-algebra-0.0.2.zip" has an error! Plugins directory is not writable or does not exist”

    You are using Personal installation of Datameer. Custom plugins deployment is not supported in the Personal/Trial edition of Datameer.

    In order to let you use the plugin, I would suggest the following workaround.

    • Stop Datameer.
    • Download the plugin (*.zip)
    • Put plugin zip file to folder  /Applications/Datameer-<version>.app/Contents/Resources/plugins/ at your Mac.
    • Start Datameer.

    After these steps you should be able to use the plugin.

    Please let me know if this will help you yo resolve the issue.

    0
Please sign in to leave a comment.